[FFmpeg-devel] [PATCH] libavdevice: make device_try_init static

Vitor Sessak vitor1001
Mon Jan 4 19:58:51 CET 2010

Diego Biurrun wrote:
> On Mon, Jan 04, 2010 at 06:32:16PM +0100, Luca Abeni wrote:
>> On 03/01/10 12:55, Diego Biurrun wrote:
>>> On Sun, Jan 03, 2010 at 11:45:28AM +0100, Luca Abeni wrote:
>>>> On 02/01/10 10:44, Reinhard Tartler wrote:
>>>>> $subj.
>>>> Patch applied, thanks! BTW, do you have some automated scripts or tools
>>>> for performing this kind of checks? It could be interesting to integrate
>>>> them in FATE, or similar...
>>> -Wmissing-prototypes
>>> -Wmissing-declarations
>> Thanks for the information, this is very useful!
>> What about adding those switches to ffmpeg compilation? I do not know  
>> the build system very much, but I am wondering if the attached patch is  
>> acceptable.
> I played with it some time ago.  However, I still wonder what the
> difference between both is.  Enlightenment welcome.
>> I tested it, and it even produced some new warnings ;-)
> Did you fix them? :)
> Attached is a list of warnings produced by -Wmissing-prototypes.
> They all look sensible.

> libavcodec/qcelpdec.c:601: warning: no previous prototype for ?interpolate_lpc?

This is easy to fix, a "static" qualifier was missing. Patch attached, 
will apply in a couple of days if no comment.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: static_qcelp.diff
Type: text/x-patch
Size: 551 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100104/df09faa7/attachment.bin>

More information about the ffmpeg-devel mailing list