[FFmpeg-devel] [PATCH] libavdevice: make device_try_init static

Diego Biurrun diego
Mon Jan 4 20:07:46 CET 2010

On Mon, Jan 04, 2010 at 07:58:51PM +0100, Vitor Sessak wrote:
> Diego Biurrun wrote:
>> On Mon, Jan 04, 2010 at 06:32:16PM +0100, Luca Abeni wrote:
>>> On 03/01/10 12:55, Diego Biurrun wrote:
>>>> On Sun, Jan 03, 2010 at 11:45:28AM +0100, Luca Abeni wrote:
>>>>> On 02/01/10 10:44, Reinhard Tartler wrote:
>>>>>> $subj.
>>>>> Patch applied, thanks! BTW, do you have some automated scripts or tools
>>>>> for performing this kind of checks? It could be interesting to integrate
>>>>> them in FATE, or similar...
>>>> -Wmissing-prototypes
>>>> -Wmissing-declarations
>>> Thanks for the information, this is very useful!
>>> What about adding those switches to ffmpeg compilation? I do not know 
>>>  the build system very much, but I am wondering if the attached patch 
>>> is  acceptable.
>> I played with it some time ago.  However, I still wonder what the
>> difference between both is.  Enlightenment welcome.
>>> I tested it, and it even produced some new warnings ;-)
>> Did you fix them? :)
>> Attached is a list of warnings produced by -Wmissing-prototypes.
>> They all look sensible.
>> libavcodec/qcelpdec.c:601: warning: no previous prototype for ?interpolate_lpc?
> This is easy to fix, a "static" qualifier was missing. Patch attached,  
> will apply in a couple of days if no comment.

Geez, just apply right away.  Sending patches for such trivialities is
just spam and useless delay.


More information about the ffmpeg-devel mailing list